中文乐高

 找回密码
 马上注册

QQ登录

只需一步,快速开始

查看: 61056|回复: 87

EV3教育版解魔方成功!!!

    [复制链接]
发表于 2013-12-28 14:51:25 | 显示全部楼层 |阅读模式
本帖最后由 zkmonkey 于 2013-12-28 16:02 编辑

搭建方式和程序均参考EV3版的MindCuber搭建及程序下载http://bbs.cmnxt.com/forum.php?m ... 12217&fromuid=27615
(出处: 中文乐高)

在此郑重感谢其无私分享!!!!

因为买的教育版,客服了部分零件不一致的困难,动用了部分9398和8043(已经混在一起了)的零件,完成搭建工作。

在实际测试程序时候,因为没有红外传感器,所以要尝试修改程序。

经过反复测试,最后直接删除红外传感器模块对应的程序就可以实现解魔方。

最后发几张图片和翻译的说明文件,供大家参考!

因为删除了部分程序,所以解完一次魔方,程序继续运行,正在研究通过超声波测距来判断是否已放入魔方,和结束程序。
IMG_4745-.jpg

IMG_4746-.jpg

translate.rar (915.62 KB, 下载次数: 11768)
如果您觉得我的帖子对您有用,请不吝给我一个“赞”!
发表于 2013-12-29 11:13:02 | 显示全部楼层
LZ你好,为什么我每次刚运行程序,解魔方机器人刚开始运行了,颜色探测器和臂杆动一下,但是马上又停止运行了,这是怎么回事呢?
如果您觉得我的帖子对您有用,请不吝给我一个“赞”!
回复 支持 2 反对 0

使用道具 举报

发表于 2013-12-29 13:59:36 | 显示全部楼层
若缺 发表于 2013-12-29 11:13
LZ你好,为什么我每次刚运行程序,解魔方机器人刚开始运行了,颜色探测器和臂杆动一下,但是马上又停止运行 ...

也出现这情况,求解
如果您觉得我的帖子对您有用,请不吝给我一个“赞”!
回复 支持 1 反对 0

使用道具 举报

 楼主| 发表于 2013-12-29 08:20:43 | 显示全部楼层
math_comix 发表于 2013-12-28 23:47
请问……只用core set和扩展套可以拼出来吗?

可以!
翻转手臂的装饰挡板是8043的。

印象中需要替换的零件不太多,需要稍微思考替换方案即可。大概有以下几处:
1、颜色识别的支撑链接,因零件不足需要自己想替代方案,确保长度、角度一致即可。
2、有大概40%的零件颜色标记不一致,需要细心,不要弄错了。
3、有一个零件教育版就没有,一共需要3个,稍后上图。
如果您觉得我的帖子对您有用,请不吝给我一个“赞”!
回复 支持 1 反对 0

使用道具 举报

 楼主| 发表于 2013-12-28 14:53:19 | 显示全部楼层
小车是9398的零件组装的,但是因为解魔方需要部分零件,拆散了一部分。
因为传动结构简单,跑的非常快,当然撞墙也很心疼,可以漂移哦!
如果您觉得我的帖子对您有用,请不吝给我一个“赞”!
发表于 2013-12-28 23:47:51 | 显示全部楼层
请问……只用core set和扩展套可以拼出来吗?
如果您觉得我的帖子对您有用,请不吝给我一个“赞”!
发表于 2013-12-29 11:34:52 | 显示全部楼层
楼主,你这个翻译的说明为什么打不开啊
如果您觉得我的帖子对您有用,请不吝给我一个“赞”!
 楼主| 发表于 2013-12-29 20:43:38 | 显示全部楼层
若缺 发表于 2013-12-29 11:13
LZ你好,为什么我每次刚运行程序,解魔方机器人刚开始运行了,颜色探测器和臂杆动一下,但是马上又停止运行 ...

你是用教育套装组装的吧!
如果是,那就需修改一下程序。
目前有2种方案:
1、直接删除主程序中 2处 切换 红外传感器的地方;
2、或者修改这两处红外传感器代码,我是改成了超声波传感器。
如果您觉得我的帖子对您有用,请不吝给我一个“赞”!
 楼主| 发表于 2013-12-29 20:45:09 | 显示全部楼层
leeyzz 发表于 2013-12-29 13:59
也出现这情况,求解

两种方法,具体看8楼。

改成超声波传感器,目前还有一个问题,就是距离设置成7-15CM都可以,但是貌似起不到作用,还是无法判断是否已放入魔方。程序自动运行。
如果您觉得我的帖子对您有用,请不吝给我一个“赞”!
发表于 2013-12-30 17:09:00 | 显示全部楼层
zkmonkey 发表于 2013-12-29 20:45
两种方法,具体看8楼。

改成超声波传感器,目前还有一个问题,就是距离设置成7-15CM都可以,但是貌似 ...

我是用31313的,很奇怪还是碰到这样的问题,难道是我的红外线感应器是坏的?
如果您觉得我的帖子对您有用,请不吝给我一个“赞”!
 楼主| 发表于 2013-12-30 22:13:10 | 显示全部楼层
若缺 发表于 2013-12-30 17:09
我是用31313的,很奇怪还是碰到这样的问题,难道是我的红外线感应器是坏的?

因为我没有31313,所以不好回答,不过从程序上看,直接删除红外感应器部分,可以直接解决这个问题。
因为判断的值是20,看说明解释为非常近,范围是0-100,是不是调整成30或者40会好一些。
如果您觉得我的帖子对您有用,请不吝给我一个“赞”!
发表于 2014-1-3 11:17:13 | 显示全部楼层
我的屏幕上也显示“find solver”,指示灯一直闪烁红灯,重复放入拿走魔方,没有任何反应?这是怎么回事??请楼主指点啊!
如果您觉得我的帖子对您有用,请不吝给我一个“赞”!
 楼主| 发表于 2014-1-4 17:01:51 | 显示全部楼层
错轨流星 发表于 2014-1-3 11:17
我的屏幕上也显示“find solver”,指示灯一直闪烁红灯,重复放入拿走魔方,没有任何反应?这是怎么回事? ...

程序的问题,红外传感器的阀值有问题,如果仅仅是为了解魔方,完全可以直接删除红外传感器部分程序。
如果您觉得我的帖子对您有用,请不吝给我一个“赞”!
发表于 2014-1-28 22:58:26 | 显示全部楼层
请问一下,我也是用教育版拼的魔方机器人,为什么机器人在运行程序后就一直扫描魔方?
如果您觉得我的帖子对您有用,请不吝给我一个“赞”!
发表于 2014-1-29 09:32:37 | 显示全部楼层
我要向前飞 发表于 2014-1-28 22:58
请问一下,我也是用教育版拼的魔方机器人,为什么机器人在运行程序后就一直扫描魔方?

你看下是不是扫瞄3次后停止,然后说颜色扫瞄错误?
如果您觉得我的帖子对您有用,请不吝给我一个“赞”!
您需要登录后才可以回帖 登录 | 马上注册

本版积分规则


QQ|中文乐高 ( 桂ICP备11003955号-1

GMT+8, 2017-6-23 13:06 , Processed in 0.106231 second(s), 28 queries .

Powered by Discuz! X3.3

© 2001-2013 Comsenz Inc. Template By 【未来科技】【 www.veikei.com 】

快速回复 返回顶部 返回列表